Package Administrtaion

/var/sadm/install/contents file has all the details about installed packages.

# grep showrev /var/sadm/install/contents -- Will show whether showrev package is installed or not

 /var/sadm/pkg directory maintains a record of all installed packages

# pkginfo | more -- Will show all installed packages
# pkginfo –l SUNWman -- Shows information about SUNWman package
# pkginfo –d /cdrom/cdrom0/s0/Solaris_9/Product | more -- To view info about pkg in CD

# pkgadd –d /cdrom/cdrom0/Solaris_9/Product SUNWxip --

# pkgchk SUNWman -- If the pkgchk command doesn’t display a message, it indicates the package was installed successfully
# pkgchk –v SUNWzip -- To list the files contained in a software package
# pkgchk –p /etc/shadow -- To determine if the contents and attributes of a file have changed since it was installed with its software package
# pkgchk –l SUNWman -- Lists info about selected diles that make up a package

# pkgrm SUNWzip -- Will remove the SUNWzip package


# pkgadd –d /cdrom/cdrom0/Solaris_9/Product –s spool SUNWzip
It will dump the SUNWzip package to /var/spool/pkg folder. Alternate path can be given instead of spool like /pkg etc.,

# pkgrm –s spool SUNWman -- Will delete the dumped SUNWman package from spool directory

# admintool & -- Tool (GUI) used to add users, printers, groups, softwares etc.,
# prodreg & -- Tool (GUI) to view installed packages as well as to install & uninstall packages.

No comments: